We are updated to SA-MP 0.3 RC8, and require you to download a new client to connect.

[Download] - sa-mp-0.3-RC8-4_beta.exe